GitHub Advisoryadvisory · Packagist

GHSA-m367-445c-2xqr Moodle has an authenticated remote code execution risk in the Moodle LMS EQUELLA repository

HIGH Published 2025-04-25 Modified 2025-04-25 Official page ↗
Aliases
CVE-2025-3642
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-94
Reviewed
2025-04-25

Affected packages

• Packagist moodle/moodle: < 4.1.18 → fixed in 4.1.18 • Packagist moodle/moodle: >= 4.3.0-beta, < 4.3.12 → fixed in 4.3.12 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.8 → fixed in 4.4.8 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.4 → fixed in 4.5.4

Description

A flaw was found in Moodle. A remote code execution risk was identified in the Moodle LMS EQUELLA repository. By default, this was only available to teachers and managers on sites with the EQUELLA repository enabled.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References