GitHub Advisoryadvisory · Packagist

GHSA-m37g-mwcg-7j7v Moodle Improper Encoding or Escaping of Output

MEDIUM Published 2022-09-30 Modified 2024-04-23 Official page ↗
Aliases
CVE-2021-40694
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-116
Reviewed
2024-04-23

Affected packages

• Packagist moodle/moodle: >= 3.9, < 3.9.10 → fixed in 3.9.10 • Packagist moodle/moodle: >= 3.10, < 3.10.7 → fixed in 3.10.7 • Packagist moodle/moodle: >= 3.11, < 3.11.3 → fixed in 3.11.3

Description

Insufficient escaping of the LaTeX preamble made it possible for site administrators to read files available to the HTTP server system account.

Related

Alias · CVE (1)

  • CVE-2021-40694 Insufficient escaping of the LaTeX preamble made it possible for site administrators to read files available to the HTTP server system… vulnerability

Weakness · CWE (1)

  • CWE-116 Improper Encoding or Escaping of Output weakness

References