GitHub Advisoryadvisory · Maven
GHSA-m3p3-2gp6-ghq8 Stored Cross-site Scripting vulnerability in Jenkins Jira Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2022-29041
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:jira
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-02
Affected packages
• Maven org.jenkins-ci.plugins:jira: >= 3.7.0, < 3.7.1 → fixed in 3.7.1
• Maven org.jenkins-ci.plugins:jira: < 3.6.1 → fixed in 3.6.1
Description
Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Exploitation of this vulnerability requires that parameters are listed on another page, like the \"Build With Parameters\" and \"Parameters\" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the \"Build With Parameters\" and \"Parameters\" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.
Related
Alias · CVE (1)
- CVE-2022-29041 Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness