GitHub Advisoryadvisory · RubyGems

GHSA-m3q7-rj8g-m457 ember-source Cross-site Scripting vulnerability

MEDIUM Published 2018-08-28 Modified 2023-01-26 Official page ↗
Aliases
CVE-2015-7565
Ecosystem
RubyGems
Packages
ember-source
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• RubyGems ember-source: >= 1.8.0, < 1.11.4 → fixed in 1.11.4 • RubyGems ember-source: >= 1.12.0, < 1.12.2 → fixed in 1.12.2 • RubyGems ember-source: >= 1.13.0, < 1.13.12 → fixed in 1.13.12 • RubyGems ember-source: >= 2.0.0, < 2.0.3 → fixed in 2.0.3 • RubyGems ember-source: >= 2.1.0, < 2.1.2 → fixed in 2.1.2 • RubyGems ember-source: >= 2.2.0, < 2.2.1 → fixed in 2.2.1

Description

Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.

Related

Alias · CVE (1)

  • CVE-2015-7565 Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References