GitHub Advisoryadvisory · Maven

GHSA-m3x6-9v6h-4g28 Cross-site Scripting in Apache Struts

MEDIUM Published 2022-05-14 Modified 2022-11-03 Official page ↗
Aliases
CVE-2016-4003
Ecosystem
Maven
Packages
org.apache.struts:struts2-core
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-11-03

Affected packages

• Maven org.apache.struts:struts2-core: >= 2.0.0, < 2.3.28 → fixed in 2.3.28

Description

Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x before 2.3.28, when using a single byte page encoding, allows remote attackers to inject arbitrary web script or HTML via multi-byte characters in a url-encoded parameter.

Related

Alias · CVE (1)

  • CVE-2016-4003 Cross-site scripting (XSS) vulnerability in the URLDecoder function in JRE before 1.8, as used in Apache Struts 2.x before 2.3.28, when… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References