GitHub Advisoryadvisory · Packagist

GHSA-m3xp-4hf3-qfpp Moodle allows remote attackers to obtain sensitive information

MEDIUM Published 2022-05-13 Modified 2025-04-12 Official page ↗
Aliases
CVE-2011-4283
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U
Weaknesses
CWE-200
Reviewed
2025-04-12

Affected packages

• Packagist moodle/moodle: >= 1.9.0, < 1.9.11 → fixed in 1.9.11 • Packagist moodle/moodle: >= 2.0.0, < 2.0.2 → fixed in 2.0.2

Description

Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.

Related

Alias · CVE (1)

  • CVE-2011-4283 Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References