GitHub Advisoryadvisory · PyPI

GHSA-m429-fhmv-c6q2 Improper Verification of Cryptographic Signature in ansible

MEDIUM Published 2021-04-20 Modified 2024-11-18 Official page ↗
Aliases
CVE-2020-14365
Ecosystem
PyPI
Packages
ansible
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-347
Reviewed
2021-04-02

Affected packages

• PyPI ansible: >= 2.8.0a1, < 2.8.15 → fixed in 2.8.15 • PyPI ansible: >= 2.9.0a1, < 2.9.13 → fixed in 2.9.13

Description

A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing packages using the dnf module. GPG signatures are ignored during installation even when `disable_gpg_check` is set to `False`, which is the default behavior. This flaw leads to malicious packages being installed on the system and arbitrary code executed via package installation scripts. The highest threat from this vulnerability is to integrity and system availability.

Related

Alias · CVE (1)

  • CVE-2020-14365 A flaw was found in the Ansible Engine, in ansible-engine 2.8.x before 2.8.15 and ansible-engine 2.9.x before 2.9.13, when installing… vulnerability

Weakness · CWE (1)

  • CWE-347 Improper Verification of Cryptographic Signature weakness

References