GitHub Advisoryadvisory · Packagist
GHSA-m434-m5pv-p35w Insufficient user authorization in Moodle
LOW
Official page ↗
- Aliases
- CVE-2022-0333
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-01-26
Affected packages
• Packagist moodle/moodle: >= 3.11, < 3.11.5 → fixed in 3.11.5
• Packagist moodle/moodle: >= 3.10, < 3.10.8 → fixed in 3.10.8
• Packagist moodle/moodle: >= 3.9, < 3.9.11 → fixed in 3.9.11
Description
A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. The calendar:manageentries capability allowed managers to access or modify any calendar event, but should have been restricted from accessing user level events.
Related
Alias · CVE (1)
- CVE-2022-0333 A flaw was found in Moodle in versions 3.11 to 3.11.4, 3.10 to 3.10.8, 3.9 to 3.9.11 and earlier unsupported versions. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness