GitHub Advisoryadvisory · PyPI
GHSA-m45c-v46h-c788 lollms path traversal vulnerability allows overriding of config.yaml file, leading to RCE
HIGH
Official page ↗
- Aliases
- CVE-2024-5824
- Ecosystem
- PyPI
- Packages
- lollms
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-22
- Reviewed
- 2024-06-28
Affected packages
• PyPI lollms: < 9.5.0 → fixed in 9.5.0
Description
A path traversal vulnerability in the `/set_personality_config` endpoint of parisneo/lollms version 9.4.0 allows an attacker to overwrite the `configs/config.yaml` file. This can lead to remote code execution by changing server configuration properties such as `force_accept_remote_access` and `turn_on_code_validation`.
Related
Alias · CVE (1)
- CVE-2024-5824 A path traversal vulnerability in the `/set_personality_config` endpoint of parisneo/lollms version 9.4.0 allows an attacker to overwrite… vulnerability
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness