GitHub Advisoryadvisory · PyPI

GHSA-m4f6-vcj4-w5mx snowflake-connector-python vulnerable to insecure deserialization of the OCSP response cache

MEDIUM Published 2025-01-29 Modified 2025-04-09 Official page ↗
Aliases
CVE-2025-24794
Ecosystem
PyPI
Packages
snowflake-connector-python
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2025-01-29

Affected packages

• PyPI snowflake-connector-python: >= 2.7.12, < 3.13.1 → fixed in 3.13.1

Description

Issue Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1. Vulnerability Details The OCSP response cache is saved locally on the machine running the Connector using the pickle serialization format. This can potentially lead to local privilege escalation if an attacker has write access to the OCSP response cache file. Solution Snowflake released version 3.13.1 of the Snowflake Connector for Python, which fixes this issue. We recommend users upgrade to version 3.13.1. Additional Information If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne. For more information, please see our Vulnerability Disclosure Policy.

Related

Alias · CVE (1)

  • CVE-2025-24794 The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References