GitHub Advisoryadvisory · PyPI
GHSA-m4hc-m2v6-hfw8 Improper authorization on debug and artifact file downloads
HIGH
Official page ↗
- Aliases
- CVE-2023-36826
- Ecosystem
- PyPI
- Packages
- sentry
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-285
- Reviewed
- 2023-07-25
Affected packages
• PyPI sentry: >= 8.21.0, < 23.5.2 → fixed in 23.5.2
Description
Impact
An authenticated user can download a debug or artifact bundle from arbitrary organizations and projects with a known bundle ID. The user does not need to be a member of the organization or have permissions on the project.
Patches
A patch was issued to ensure authorization checks are properly scoped on requests to retrieve debug or artifact bundles. Authenticated users who do not have the necessary permissions on the particular project are no longer able to download them.
Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version 23.5.2 or higher.
References
• Restrict file downloads to Project
Related
Alias · CVE (1)
- CVE-2023-36826 Sentry is an error tracking and performance monitoring platform. vulnerability
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://github.com/getsentry/sentry/security/advisories/GHSA-m4hc-m2v6-hfw8 web
- https://nvd.nist.gov/vuln/detail/CVE-2023-36826 advisory
- https://github.com/getsentry/sentry/pull/49680 web
- https://github.com/getsentry/sentry/commit/e932b15435bf36239431eaa3790a6bcfa47046a9 web
- https://github.com/getsentry/sentry package
- https://github.com/pypa/advisory-database/tree/main/vulns/sentry/PYSEC-2023-130.yaml web