GitHub Advisoryadvisory · Packagist

GHSA-m4wj-hhwj-47qp Drupal Core Cross-Site Scripting (XSS) Vulnerability

LOW Published 2025-04-01 Modified 2026-04-06 Official page ↗
Aliases
CVE-2025-31675
Ecosystem
Packagist
Packages
drupal/core
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2025-04-01

Affected packages

• Packagist drupal/core: >= 8.0.0, < 10.3.14 → fixed in 10.3.14 • Packagist drupal/core: >= 10.4.0, < 10.4.5 → fixed in 10.4.5 • Packagist drupal/core: >= 11.0.0, < 11.0.13 → fixed in 11.0.13 • Packagist drupal/core: >= 11.1.0, < 11.1.5 → fixed in 11.1.5

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS).This issue affects Drupal core: from 8.0.0 before 10.3.14, from 10.4.0 before 10.4.5, from 11.0.0 before 11.0.13, from 11.1.0 before 11.1.5.

Related

Alias · CVE (1)

  • CVE-2025-31675 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Drupal core allows Cross-Site… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References