GitHub Advisoryadvisory · npm

GHSA-m52x-29pq-w3vv Pannellum Cross-Site Scripting due to data not being sanitized for URIs or vbscript

MEDIUM Published 2019-11-22 Modified 2022-08-03 Official page ↗
Aliases
CVE-2019-16763
Ecosystem
npm
Packages
pannellum
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• npm pannellum: >= 2.5.0, < 2.5.5 → fixed in 2.5.5

Description

Versions of `pannellum` prior to 2.5.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize URLs for data URIs, which may allow attackers to execute arbitrary code in a victim's browser. Recommendation Upgrade to version 2.5.6 or later.

Related

Alias · CVE (1)

  • CVE-2019-16763 In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References