GitHub Advisoryadvisory · Packagist
GHSA-m58f-9pvv-8mp2 Moodle vulnerable to brute-force password guesses
HIGH
Official page ↗
- Aliases
- CVE-2025-62399
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-307
- Reviewed
- 2025-10-24
Affected packages
• Packagist moodle/moodle: >= 5.0.0-beta, < 5.0.3 → fixed in 5.0.3
• Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.7 → fixed in 4.5.7
• Packagist moodle/moodle: >= 4.2.0-beta, < 4.4.11 → fixed in 4.4.11
• Packagist moodle/moodle: < 4.1.21 → fixed in 4.1.21
Description
Moodle's mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible to brute-force attacks.
Related
Alias · CVE (1)
- CVE-2025-62399 Moodle’s mobile and web service authentication endpoints did not sufficiently restrict repeated password attempts, making them susceptible… vulnerability
Weakness · CWE (1)
- CWE-307 Improper Restriction of Excessive Authentication Attempts weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-62399 advisory
- https://github.com/moodle/moodle/commit/e4d02567c922c537086de9f59f063ca073552a3a web
- https://access.redhat.com/security/cve/CVE-2025-62399 web
- https://bugzilla.redhat.com/show_bug.cgi?id=2404432 web
- https://github.com/moodle/moodle package
- https://moodle.org/mod/forum/discuss.php?d=470388 web