GitHub Advisoryadvisory · Maven

GHSA-m59c-jpc8-m2x4 In Apache Tomcat there is an improper handing of overflow in the UTF-8 decoder

HIGH Published 2018-10-17 Modified 2024-02-23 Official page ↗
Aliases
CVE-2018-1336
Ecosystem
Maven
Packages
org.apache.tomcat.embed:tomcat-embed-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-835
Reviewed
2020-06-16

Affected packages

• Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.0.M9, < 9.0.8 → fixed in 9.0.8 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.0, < 8.5.31 → fixed in 8.5.31 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.0.0RC1, < 8.0.51 → fixed in 8.0.51 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 7.0.28, < 7.0.87 → fixed in 7.0.87

Description

An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a Denial of Service. Versions Affected: Apache Tomcat 9.0.0.M9 to 9.0.7, 8.5.0 to 8.5.30, 8.0.0.RC1 to 8.0.51, and 7.0.28 to 7.0.86.

Related

Alias · CVE (1)

  • CVE-2018-1336 An improper handing of overflow in the UTF-8 decoder with supplementary characters can lead to an infinite loop in the decoder causing a… vulnerability

Weakness · CWE (1)

  • CWE-835 Loop with Unreachable Exit Condition weakness

References