GitHub Advisoryadvisory · PyPI
GHSA-m5gw-83w2-7749 Apache Fory PyFory Deserialization of Untrusted Data
CRITICAL
Official page ↗
- Aliases
- CVE-2026-48207
- Ecosystem
- PyPI
- Packages
- pyfory
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2026-06-30
Affected packages
• PyPI pyfory: >= 0.13.0, < 1.0.0 → fixed in 1.0.0
Description
Fory PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes.
This issue affects Apache Fory: from before 1.0.0.
Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.
Related
Alias · CVE (1)
- CVE-2026-48207 Deserialization of untrusted data in Apache Fory PyFory. vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness