GitHub Advisoryadvisory · npm
GHSA-m5p9-xvxj-64c8 Flowise and Flowise Chat Embed vulnerable to Stored Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2024-9148
- Ecosystem
- npm
- Packages
- flowise-embed, flowise
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79
- Reviewed
- 2024-09-30
Affected packages
• npm flowise-embed: < 2.0.0 → fixed in 2.0.0
• npm flowise: < 2.1.1 → fixed in 2.1.1
Description
Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.
Related
Alias · CVE (1)
- CVE-2024-9148 Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-9148 advisory
- https://github.com/FlowiseAI/Flowise/commit/8375ebb4ec1ebb2b1295561cc0f63486a29f3fde web
- https://github.com/FlowiseAI/FlowiseChatEmbed/commit/6a9645df41371cb69f251038d501ec87b1304c84 web
- https://github.com/FlowiseAI/Flowise/releases/tag/flowise%402.1.1 web
- https://github.com/FlowiseAI/FlowiseChatEmbed package
- https://github.com/FlowiseAI/FlowiseChatEmbed/releases/tag/flowise-embed%402.0.0 web
- https://www.tenable.com/security/research/tra-2024-40 web