GitHub Advisoryadvisory · Maven
GHSA-m5r7-w9v3-ghmx Cross-site Scripting in Apache NiFi
MEDIUM
Official page ↗
- Aliases
- CVE-2017-7665
- Ecosystem
- Maven
- Packages
- org.apache.nifi:nifi
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-11-01
Affected packages
• Maven org.apache.nifi:nifi: < 0.7.4 → fixed in 0.7.4
• Maven org.apache.nifi:nifi: >= 1.0.0, < 1.3.0 → fixed in 1.3.0
Description
In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.
Related
Alias · CVE (1)
- CVE-2017-7665 In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness