GitHub Advisoryadvisory · Packagist
GHSA-m5v7-pr32-mjx2 Critical severity vulnerability in Ignition
CRITICAL
Official page ↗
- Aliases
- CVE-2020-13909
- Ecosystem
- Packagist
- Packages
- facade/ignition
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Reviewed
- 2021-10-08
Affected packages
• Packagist facade/ignition: >= 2.0.0, < 2.0.5 → fixed in 2.0.5
• Packagist facade/ignition: < 1.16.15 → fixed in 1.16.15
Description
The Ignition page before version 2.0.5 for Laravel mishandles globals, _get, _post, _cookie, and _env.
NOTE: in the 1.x series, versions 1.16.15 and later are unaffected as a consequence of the CVE-2021-43996 fix.
Related
Alias · CVE (1)
- CVE-2020-13909 The Ignition component before 2.0.5 for Laravel mishandles globals, _get, _post, _cookie, and _env. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-13909 advisory
- https://github.com/github/advisory-database/issues/2316 web
- https://github.com/facade/ignition package
- https://github.com/facade/ignition/compare/2.0.4...2.0.5 web
- https://github.com/facade/ignition/releases/tag/2.0.5 web
- https://www.cve.org/CVERecord?id=CVE-2020-13909 web