GitHub Advisoryadvisory · Packagist
GHSA-m5vr-3m74-jwxp Missing Required Cryptographic Step Leading to Sensitive Information Disclosure in TYPO3 CMS
HIGH
Official page ↗
- Aliases
- CVE-2020-15098
- Ecosystem
- Packagist
- Packages
- typo3/cms-core, typo3/cms
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20, CWE-200, CWE-325, CWE-327, CWE-502
- Reviewed
- 2020-07-29
Affected packages
• Packagist typo3/cms-core: >= 9.0.0, < 9.5.20 → fixed in 9.5.20
• Packagist typo3/cms-core: >= 10.0.0, < 10.4.6 → fixed in 10.4.6
• Packagist typo3/cms: >= 10.0.0, < 10.4.6 → fixed in 10.4.6
• Packagist typo3/cms: >= 9.0.0, < 9.5.20 → fixed in 9.5.20
Description
> ### Meta
> * CVSS: `CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C` (8.2)
> * CWE-325, CWE-20, CWE-200, CWE-502
Problem
It has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains as described below.
• TYPO3-CORE-SA-2020-007, CVE-2020-15099: Potential Privilege Escalation
+ the database server used for a TYPO3 installation must be accessible for an attacker (either via internet or shared hosting network)
+ `CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C` (7.5, high)
• TYPO3-CORE-SA-2016-013, CVE-2016-5091: Insecure Deserialization & Remote Code Execution
+ an attacker must have access to at least one Extbase plugin or module action in a TYPO3 installation
+ `CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C` (9.1, critical)
The overall severity of this vulnerability is high (8.2) based on mentioned attack chains and the requirement of having a valid backend user session (authenticated).
Solution
Update to TYPO3 versions 9.5.20 or 10.4.6 that fix the problem described.
Credits
Thanks to TYPO3 security team member Oliver Hader who reported and fixed the issue.
References
• TYPO3-CORE-SA-2020-008
Related
Alias · CVE (1)
- CVE-2020-15098 In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.20, and greater than or equal to 10.0.0 and less than 10.4.6, it has been… vulnerability
References
- https://github.com/TYPO3/TYPO3.CMS/security/advisories/GHSA-m5vr-3m74-jwxp web
- https://nvd.nist.gov/vuln/detail/CVE-2016-5091 advisory
- https://nvd.nist.gov/vuln/detail/CVE-2020-15098 advisory
- https://github.com/TYPO3/TYPO3.CMS/commit/85d3e70dff35a99ef53f4b561114acfa9e5c47e1 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms-core/CVE-2020-15098.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/CVE-2020-15098.yaml web
- https://github.com/TYPO3/TYPO3.CMS package
- https://typo3.org/security/advisory/typo3-core-sa-2016-013 web
- https://typo3.org/security/advisory/typo3-core-sa-2020-008 web