GitHub Advisoryadvisory · Packagist

GHSA-m5wg-cjgh-223j goodoneuz/pay-uz: the /payment/api/editable/update endpoint overwrites existing PHP payment hook files

CRITICAL Published 2026-04-16 Modified 2026-07-27 Official page ↗
Aliases
CVE-2026-31843
Ecosystem
Packagist
Packages
goodoneuz/pay-uz
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-284
Reviewed
2026-04-16

Affected packages

• Packagist goodoneuz/pay-uz: < 3.0.0 → fixed in 3.0.0

Description

The goodoneuz/pay-uz Laravel package (<= 2.2.24) contains a critical vulnerability in the /payment/api/editable/update endpoint that allows unauthenticated attackers to overwrite existing PHP payment hook files. The endpoint is exposed via Route::any() without authentication middleware, enabling remote access without credentials. User-controlled input is directly written into executable PHP files using file_put_contents(). These files are later executed via require() during normal payment processing workflows, resulting in remote code execution under default application behavior. The payment secret token mentioned by the vendor is unrelated to this endpoint and does not mitigate the vulnerability.

Related

Alias · CVE (1)

  • CVE-2026-31843 The goodoneuz/pay-uz Laravel package (<= 2.2.24) contains a critical vulnerability in the /payment/api/editable/update endpoint that allows… vulnerability

Weakness · CWE (1)

  • CWE-284 Improper Access Control weakness

References