GitHub Advisoryadvisory · Packagist

GHSA-m63h-q4x3-6hwj Moodle is vulnerable to Improper Input Validation in MoodleQuickForm class

MEDIUM Published 2022-05-13 Modified 2023-08-17 Official page ↗
Aliases
CVE-2013-2083
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2023-08-17

Affected packages

• Packagist moodle/moodle: < 2.2.10 → fixed in 2.2.10 • Packagist moodle/moodle: >= 2.3.0, < 2.3.7 → fixed in 2.3.7 • Packagist moodle/moodle: >= 2.4.0, < 2.4.4 → fixed in 2.4.4

Description

The MoodleQuickForm class in `lib/formslib.php` in Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly handle a certain array-element syntax, which allows remote attackers to bypass intended form-data filtering via a crafted request.

Related

Alias · CVE (1)

  • CVE-2013-2083 The MoodleQuickForm class in lib/formslib.php in Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References