GitHub Advisoryadvisory · Packagist

GHSA-m6j4-8r7p-wpp3 BuddyPress privilege escalation via REST API

HIGH Published 2021-10-06 Modified 2021-10-06 Official page ↗
Aliases
CVE-2021-21389
Ecosystem
Packagist
Packages
buddypress/buddypress
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-863
Reviewed
2021-10-06

Affected packages

• Packagist buddypress/buddypress: >= 5.0.0, < 7.2.1 → fixed in 7.2.1

Description

Impact It's possible for a non-privileged, regular user to obtain administrator rights by exploiting an issue in the BuddyPress REST API members endpoint. Patches The vulnerability has been fixed in BuddyPress 7.2.1. Existing installations of the plugin should be updated to this version to mitigate the issue. References https://buddypress.org/2021/03/buddypress-7-2-1-security-release/ For more information If you have any questions or comments about this advisory: • Open an issue in HackerOne

Related

Alias · CVE (1)

  • CVE-2021-21389 BuddyPress is an open source WordPress plugin to build a community site. vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References