GitHub Advisoryadvisory · PyPI

GHSA-m6jm-3v38-76j4 Apache Superset: Improper Neutralization of custom SQL on embedded context

MEDIUM Published 2024-02-28 Modified 2025-02-12 Official page ↗
Aliases
CVE-2024-24772
Ecosystem
PyPI
Packages
apache-superset
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-20, CWE-89
Reviewed
2024-02-28

Affected packages

• PyPI apache-superset: < 3.0.4 → fixed in 3.0.4 • PyPI apache-superset: >= 3.1.0, < 3.1.1 → fixed in 3.1.1

Description

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Related

Alias · CVE (1)

  • CVE-2024-24772 A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying… vulnerability

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References