GitHub Advisoryadvisory · Packagist

GHSA-m6pf-cm3f-7876 LibreNMS Cross-site Scripting vulnerability

HIGH Published 2023-08-15 Modified 2023-08-15 Official page ↗
Aliases
CVE-2023-4347
Ecosystem
Packagist
Packages
librenms/librenms
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
Weaknesses
CWE-79
Reviewed
2023-08-15

Affected packages

• Packagist librenms/librenms: < 23.8.0 → fixed in 23.8.0

Description

Cross-site Scripting (XSS) - Reflected in GitHub repository librenms/librenms 23.7.0 and prior. A patch is available at commit 91c57a1ee54631e071b6b0c952d99c8ee892e824 and anticiapted to be part of version 23.8.0.

Related

Alias · CVE (1)

  • CVE-2023-4347 Cross-site Scripting (XSS) - Reflected in GitHub repository librenms/librenms prior to 23.8.0. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References