GitHub Advisoryadvisory · npm

GHSA-m75h-cghq-c8h5 Heap Based Buffer Overflow in libyaml

CRITICAL Published 2020-08-31 Modified 2021-09-23 Official page ↗
Aliases
CVE-2013-6393
Ecosystem
npm
Packages
libyaml
Severity
Critical
Weaknesses
CWE-119
Reviewed
2020-08-31

Affected packages

• npm libyaml: < 0.2.3 → fixed in 0.2.3

Description

Versions 0.2.2 and earlier depend on native libyaml version 0.1.5 or earlier. As such, they are affected by a heap-based buffer overflow vulnerability that may result in a crash or arbitrary code execution when parsing YAML tags. Recommendation • Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.

Related

Alias · CVE (1)

  • CVE-2013-6393 The yaml_parser_scan_tag_uri function in scanner.c in LibYAML before 0.1.5 performs an incorrect cast, which allows remote attackers to… vulnerability

Weakness · CWE (1)

  • CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer weakness

References