GitHub Advisoryadvisory · npm
GHSA-m852-866j-69j8 Malicious Package in eslint-config-airbnb-standard
CRITICAL
Official page ↗
- Ecosystem
- npm
- Packages
- eslint-config-airbnb-standard
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-506
- Reviewed
- 2020-08-31
Affected packages
• npm eslint-config-airbnb-standard: >= 2.0.0, < 2.1.0 → fixed in 2.1.0
Description
Version 2.0.0 of `eslint-config-airbnb-standard` was published with a bundled version of `eslint-scope` that was found to contain malicious code. This code would read the users `.npmrc` file and send it's contents to a remote server.
Recommendation
The best course of action if you found this package installed in your environment is to revoke all your npm tokens and use a different version of the module. You can find instructions on how to do that here. https://docs.npmjs.com/getting-started/working_with_tokens#how-to-revoke-tokens
Related
Weakness · CWE (1)
- CWE-506 Embedded Malicious Code weakness