GitHub Advisoryadvisory · Packagist
GHSA-m8fw-p3cr-6jqc Cross-Site Scripting in CKEditor4 WordCount Plugin
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- typo3/cms-rte-ckeditor
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2023-07-25
Affected packages
• Packagist typo3/cms-rte-ckeditor: >= 9.5.0, < 9.5.42 → fixed in 9.5.42
• Packagist typo3/cms-rte-ckeditor: >= 10.0.0, < 10.4.39 → fixed in 10.4.39
• Packagist typo3/cms-rte-ckeditor: >= 11.0.0, < 11.5.30 → fixed in 11.5.30
Description
> ### CVSS: `CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C` (4.4)
Problem
The WordCount plugin (`npm:ckeditor-wordcount-plugin`) for CKEditor4 is vulnerable to cross-site scripting when switching to the source code mode. This plugin is enabled via the `Full.yaml` configuration present, but is not active in the default configuration.
In default scenarios, exploiting this vulnerability requires a valid backend user account. However, if custom plugins are used on the website frontend, which accept and reflect rich-text content submitted by users, no authentication is required.
Solution
Update to TYPO3 versions 9.5.42 ELTS, 10.4.39 ELTS, 11.5.30 that fix the problem described above.
Credits
Thanks to Sybille Peters who reported this issue, and to TYPO3 core & security team member Oliver Hader who fixed the issue.
References
• TYPO3-CORE-SA-2023-004
• https://github.com/w8tcha/CKEditor-WordCount-Plugin/security/advisories/GHSA-q9w4-w667-qqj4
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness