GitHub Advisoryadvisory · Packagist
GHSA-m8xh-cqc2-5q6f Type Confusion in ImpressCMS
CRITICAL
Official page ↗
- Aliases
- CVE-2021-26600
- Ecosystem
- Packagist
- Packages
- impresscms/impresscms
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-843
- Reviewed
- 2022-04-01
Affected packages
• Packagist impresscms/impresscms: < 1.4.3 → fixed in 1.4.3
Description
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
Related
Alias · CVE (1)
- CVE-2021-26600 ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==). vulnerability
Weakness · CWE (1)
- CWE-843 Access of Resource Using Incompatible Type weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-26600 advisory
- https://hackerone.com/reports/1081986 web
- https://github.com/ImpressCMS/impresscms package
- https://github.com/ImpressCMS/impresscms/releases/tag/v1.4.3 web
- http://karmainsecurity.com/KIS-2022-01 web
- http://packetstormsecurity.com/files/166393/ImpressCMS-1.4.2-Authentication-Bypass.html web
- http://seclists.org/fulldisclosure/2022/Mar/43 web