GitHub Advisoryadvisory · Maven

GHSA-m93h-5qmx-pphg Improper Authentication in Jenkins

MEDIUM Published 2022-05-13 Modified 2022-07-01 Official page ↗
Aliases
CVE-2017-2604
Ecosystem
Maven
Packages
org.jenkins-ci.main:jenkins-core
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-287
Reviewed
2022-07-01

Affected packages

• Maven org.jenkins-ci.main:jenkins-core: < 2.32.2 → fixed in 2.32.2 • Maven org.jenkins-ci.main:jenkins-core: >= 2.34, < 2.44 → fixed in 2.44

Description

In Jenkins before versions 2.44 and 2.32.2, low privilege users were able to act on administrative monitors due to them not being consistently protected by permission checks (SECURITY-371).

Related

Alias · CVE (1)

  • CVE-2017-2604 In Jenkins before versions 2.44, 2.32.2 low privilege users were able to act on administrative monitors due to them not being consistently… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References