GitHub Advisoryadvisory · PyPI

GHSA-m982-7q3h-r784 Open Babel has out-of-bounds read in PQS lowerit (pre-buffer read)

MEDIUM Published 2026-07-01 Modified 2026-07-01 Official page ↗
Aliases
CVE-2025-11000
Ecosystem
PyPI
Packages
openbabel
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:L
Weaknesses
CWE-125, CWE-404
Reviewed
2026-07-01

Affected packages

• PyPI openbabel: < 3.2.0 → fixed in 3.2.0

Description

Summary A memory-safety vulnerability in Open Babel's PQS parser caused an out-of-bounds (pre-buffer) read when reading a crafted input file. Details The flaw was in the `lowerit` helper used by the PQS parser. A malformed input caused the helper to read one or more bytes before the start of its input buffer. Impact Open Babel is a C++ library and CLI used to read and write chemistry file formats; it is shipped by Linux distributions and embedded in services that may parse untrusted input. Triggering this vulnerability requires the victim to open a malicious PQS file with the `obabel` tool, the `OBConversion` API, or any of the language bindings (Python, Ruby, Java, R, Perl, C#, PHP). Affected versions All releases up to and including 3.1.1. Patched version 3.2.0 (released 2026-05-26). Patch Fix commit: https://github.com/openbabel/openbabel/commit/f4a5ebae Fixes consolidated in #2913. A minimized reproducer for this CVE is checked in under `test/files/fuzz_regress/` and is exercised on every CI build under ASAN+UBSAN by the `fuzzregresstest` harness. Credit Reported via OSS-Fuzz.

Related

Alias · CVE (1)

  • CVE-2025-11000 A vulnerability was determined in Open Babel up to 3.1.1. vulnerability

Weakness · CWE (2)

  • CWE-125 Out-of-bounds Read weakness
  • CWE-404 Improper Resource Shutdown or Release weakness

References