GitHub Advisoryadvisory · Packagist

GHSA-m98q-p5gq-q5ff eZ Publish Cross-site Scripting (XSS) vulnerability

MEDIUM Published 2022-05-14 Modified 2024-04-25 Official page ↗
Aliases
CVE-2017-1000431
Ecosystem
Packagist
Packages
ezsystems/ezpublish-legacy
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-04-25

Affected packages

• Packagist ezsystems/ezpublish-legacy: >= 5.4.0, < 5.4.10 → fixed in 5.4.10 • Packagist ezsystems/ezpublish-legacy: >= 5.3.0, < 5.3.12.1 → fixed in 5.3.12.1

Description

eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12.0 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.

Related

Alias · CVE (1)

  • CVE-2017-1000431 eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an XSS issue in the search module, resulting in a risk… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References