GitHub Advisoryadvisory · npm
GHSA-mc23-976p-j42x xterm vulnerable to remote code execution
HIGH
Official page ↗
- Aliases
- CVE-2019-0542
- Ecosystem
- npm
- Packages
- xterm
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
- Reviewed
- 2020-06-16
Affected packages
• npm xterm: < 3.8.1 → fixed in 3.8.1
• npm xterm: >= 3.9.0, < 3.9.2 → fixed in 3.9.2
• npm xterm: >= 3.10.0, < 3.10.1 → fixed in 3.10.1
Description
A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters.
Related
Alias · CVE (1)
- CVE-2019-0542 A remote code execution vulnerability exists in Xterm.js when the component mishandles special characters, aka "Xterm Remote Code Execution… vulnerability
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-0542 advisory
- https://github.com/xtermjs/xterm.js/commit/3592c641cd0348e0b698e8a180aea2072c6bcd9a web
- https://access.redhat.com/errata/RHBA-2019:0959 web
- https://access.redhat.com/errata/RHSA-2019:1422 web
- https://access.redhat.com/errata/RHSA-2019:2551 web
- https://access.redhat.com/errata/RHSA-2019:2552 web
- https://github.com/advisories/GHSA-mc23-976p-j42x advisory
- https://github.com/xtermjs/xterm.js package
- https://github.com/xtermjs/xterm.js/releases/tag/3.8.1 web
- http://www.securityfocus.com/bid/106434 web