GitHub Advisoryadvisory · Go
GHSA-mc24-7m59-4q5p Rancher CLI skips TLS verification on Rancher CLI login command
HIGH
Official page ↗
- Aliases
- CVE-2025-67601
- Ecosystem
- Go
- Packages
- github.com/rancher/rancher
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-295
- Reviewed
- 2026-02-01
Affected packages
• Go github.com/rancher/rancher: < 0.0.0-20260129092249-bb0625fd1896 → fixed in 0.0.0-20260129092249-bb0625fd1896
• Go github.com/rancher/rancher: >= 2.13.0, < 2.13.2 → fixed in 2.13.2
• Go github.com/rancher/rancher: >= 2.12.0, < 2.12.6 → fixed in 2.12.6
• Go github.com/rancher/rancher: >= 2.11.0, < 2.11.10 → fixed in 2.11.10
• Go github.com/rancher/rancher: >= 2.10.0, < 2.10.11 → fixed in 2.10.11
Description
Impact
A vulnerability has been identified within Rancher Manager, where using self-signed CA certificates and passing the `-skip-verify` flag to the Rancher CLI login command without also passing the `–cacert` flag results in the CLI attempting to fetch CA certificates stored in Rancher’s setting cacerts. This does not apply to any other commands and only applies to the login command if the `–cacert` flag was not provided.
An attacker with network-level access between the Rancher CLI and Rancher Manager could interfere with the TLS handshake to return a CA they control, despite the use of the `--skip-verify` flag. This may be abused to bypass TLS as a security control. Attackers can also see basic authentication headers in a Man-in-the-Middle due to the lack of TLS enforcement.
Please consult the associated MITRE ATT&CK - Technique - Man-in-the-Middle for further information about this category of attack.
Patches
This vulnerability is addressed by removing the ability to fetch CA certificates stored in Rancher’s setting cacerts when using the login command. Whenever required, for example when using self-signed certificates, CA certificates have to be explicitly passed with the –cacert flag.
Patched versions of Rancher include releases `v2.13.2`, `v2.12.6`, `v2.11.10`, and `v2.10.11`.
Workarounds
If a projecct can't upgrade to a fixed version, please make sure whenever required, for example when using self-signed certificates, to always explicitly pass CA certificates with the –cacert flag when using the login command.
References
If there are any questions or comments about this advisory:
• Reach out to the SUSE Rancher Security team for security related inquiries.
• Open an issue in the Rancher repository.
• Verify with the support matrix and product support lifecycle.
Note: Rancher versions beyond 2.3.0-alpha5 are no longer supported at pkg.go.dev, follow Rancher installation instructions for newer versions.
Related
Alias · CVE (1)
- CVE-2025-67601 A vulnerability has been identified within Rancher Manager, where using self-signed CA certificates and passing the -skip-verify flag to… vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/rancher/rancher/security/advisories/GHSA-mc24-7m59-4q5p web
- https://nvd.nist.gov/vuln/detail/CVE-2025-67601 advisory
- https://attack.mitre.org/techniques/T1557 web
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2025-67601 web
- https://github.com/rancher/rancher package
- https://github.com/rancher/rancher/releases/tag/v2.13.2 web