GitHub Advisoryadvisory · RubyGems, Maven

GHSA-mc6j-h948-v2p6 RubyGems Improper Verification of Cryptographic Signature vulnerability

CRITICAL Published 2022-05-14 Modified 2023-03-08 Official page ↗
Aliases
CVE-2018-1000076
Ecosystem
RubyGems, Maven
Packages
rubygems-update, org.jruby:jruby-stdlib
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-347
Reviewed
2023-03-08

Affected packages

• RubyGems rubygems-update: >= 2.2.0, < 2.7.6 → fixed in 2.7.6 • Maven org.jruby:jruby-stdlib: < 9.1.16.0 → fixed in 9.1.16.0

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, and Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contain an Improper Verification of Cryptographic Signature vulnerability in package.rb. This can result in a mis-signed gem being installed, as the tarball would contain multiple gem signatures. This vulnerability has been fixed in 2.7.6.

Related

Alias · CVE (1)

  • CVE-2018-1000076 RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5… vulnerability

Weakness · CWE (1)

  • CWE-347 Improper Verification of Cryptographic Signature weakness

References