GitHub Advisoryadvisory · PyPI

GHSA-mcrp-whpw-jp68 InvokeAI Deserialization of Untrusted Data vulnerability

CRITICAL Published 2025-03-21 Modified 2025-05-20 Official page ↗
Aliases
CVE-2024-12029
Ecosystem
PyPI
Packages
InvokeAI
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2025-03-21

Affected packages

• PyPI InvokeAI: >= 5.3.1, < 5.4.3rc2 → fixed in 5.4.3rc2

Description

A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. The vulnerability arises from unsafe deserialization of model files using torch.load without proper validation. Attackers can exploit this by embedding malicious code in model files, which is executed upon loading. This issue is fixed in version 5.4.3rc2.

Related

Alias · CVE (1)

  • CVE-2024-12029 A remote code execution vulnerability exists in invoke-ai/invokeai versions 5.3.1 through 5.4.2 via the /api/v2/models/install API. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References