GitHub Advisoryadvisory · Maven
GHSA-mcwh-c9pg-xw43 Apache Kafka Deserialization of Untrusted Data vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2025-27819
- Ecosystem
- Maven
- Packages
- org.apache.kafka:kafka_2.10, org.apache.kafka:kafka_2.11, org.apache.kafka:kafka_2.12, org.apache.kafka:kafka_2.13, org.apache.kafka:kafka_2.8.0, org.apache.kafka:kafka_2.8.2, org.apache.kafka:kafka_2.9.1, org.apache.kafka:kafka_2.9.2
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2025-06-10
Affected packages
• Maven org.apache.kafka:kafka_2.10: < 3.4.0 (no fix yet)
• Maven org.apache.kafka:kafka_2.11: < 3.4.0 (no fix yet)
• Maven org.apache.kafka:kafka_2.12: < 3.4.0 → fixed in 3.4.0
• Maven org.apache.kafka:kafka_2.13: < 3.4.0 → fixed in 3.4.0
• Maven org.apache.kafka:kafka_2.8.0: < 3.4.0 (no fix yet)
• Maven org.apache.kafka:kafka_2.8.2: < 3.4.0 (no fix yet)
• Maven org.apache.kafka:kafka_2.9.1: < 3.4.0 (no fix yet)
• Maven org.apache.kafka:kafka_2.9.2: < 3.4.0 (no fix yet)
Description
In CVE-2023-25194, we announced the RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration in Kafka Connect API. But not only Kafka Connect API is vulnerable to this attack, the Apache Kafka brokers also have this vulnerability. To exploit this vulnerability, the attacker needs to be able to connect to the Kafka cluster and have the AlterConfigs permission on the cluster resource.
Since Apache Kafka 3.4.0, we have added a system property ("-Dorg.apache.kafka.disallowed.login.modules") to disable the problematic login modules usage in SASL JAAS configuration. Also by default "com.sun.security.auth.module.JndiLoginModule" is disabled in Apache Kafka 3.4.0, and "com.sun.security.auth.module.JndiLoginModule,com.sun.security.auth.module.LdapLoginModule" is disabled by default in in Apache Kafka 3.9.1/4.0.0
Related
Alias · CVE (1)
- CVE-2025-27819 In CVE-2023-25194, we announced the RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration in Kafka Connect API. vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness