GitHub Advisoryadvisory · npm, NuGet, Packagist

GHSA-mf2p-h6hf-fcwm TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization

HIGH Published 2026-10-27 Modified 2026-10-27 Official page ↗
Aliases
CVE-2026-116675
Ecosystem
npm, NuGet, Packagist
Packages
tinymce, TinyMCE, tinymce/tinymce
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-79
Reviewed
2026-10-27

Affected packages

• npm tinymce: >= 8.5.1, < 8.9.3 → fixed in 8.9.3 • NuGet TinyMCE: >= 8.5.1, < 8.9.3 → fixed in 8.9.3 • Packagist tinymce/tinymce: >= 8.5.1, < 8.9.3 → fixed in 8.9.3 • npm tinymce: >= 7.9.3, < 7.9.4 → fixed in 7.9.4 • NuGet TinyMCE: >= 7.9.3, < 7.9.4 → fixed in 7.9.4 • Packagist tinymce/tinymce: >= 7.9.3, < 7.9.4 → fixed in 7.9.4

Description

Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled. Patches This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first. Workarounds No official workaround available. Fix To avoid this vulnerability: Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher. Acknowledgements Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.

Related

Alias · CVE (1)

  • CVE-2026-116675 TinyMCE is an open source rich text editor. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References