GitHub Advisoryadvisory · Maven

GHSA-mf4f-j588-5xm8 Apache Log4j Remote Code Execution

CRITICAL Published 2021-12-14 Modified 2021-12-14 Official page ↗
Ecosystem
Maven
Packages
org.opencastproject:opencast-common
Severity
Critical
Reviewed
2021-12-14

Affected packages

• Maven org.opencastproject:opencast-common: < 9.10 → fixed in 9.10 • Maven org.opencastproject:opencast-common: >= 10.0, < 10.6 → fixed in 10.6

Description

Impact Opencast uses an Apache Log4j2 version which, combined with older JDK versions, can be used for remote code execution attacks which have been found to be actively exploited. Apache Log4j2 <=2.14.1 JNDI features is not sufficiently protected. An attacker who can control log messages or log message parameters can execute arbitrary code when message lookup substitution is enabled. Who is affected • Opencast before 9.10 or 10.6 are affected • Log4j version: all 2.x versions before 2.15.0 are affected Patches The issue has been fixed in Opencast 9.10 and 10.6. Workarounds The vulnerability can be mitigated by setting system property `log4j2.formatMsgNoLookups` to `true`. References • Opencast pull request mitigating the vulnerability • CVE-2021-44228 Detail • Analysis and Remediation Guidance to the Log4j Zero-Day RCE (CVE-2021-44228) Vulnerability • VE-2021-44228 – Log4j 2 Vulnerability Analysis For more information If you have any questions or comments about this advisory: • Open an issue in our issue tracker • Email us at [email protected] Note about dependencies This issue affects many Java applications. Please also verify these are not vulnerable.

References