GitHub Advisoryadvisory · PyPI

GHSA-mffc-9gx5-99g3 python-kerberos vulnerable to KDC spoofing attacks

CRITICAL Published 2022-05-14 Modified 2024-09-27 Official page ↗
Aliases
CVE-2015-3206
Ecosystem
PyPI
Packages
kerberos, pykerberos
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287
Reviewed
2024-02-23

Affected packages

• PyPI kerberos: <= 1.2.5 (no fix yet) • PyPI pykerberos: < 1.1.6 → fixed in 1.1.6

Description

The `checkPassword` function in python-kerberos does not authenticate the KDC it attempts to communicate with, which allows remote attackers to cause a denial of service (bad response), or have other unspecified impact by performing a man-in-the-middle attack.

Related

Alias · CVE (1)

  • CVE-2015-3206 The checkPassword function in python-kerberos does not authenticate the KDC it attempts to communicate with, which allows remote attackers… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References