GitHub Advisoryadvisory · PyPI

GHSA-mfpj-3qhm-976m Uncontrolled Resource Consumption in asyncua and opcua

HIGH Published 2022-08-24 Modified 2022-09-30 Official page ↗
Aliases
CVE-2022-25304
Ecosystem
PyPI
Packages
asyncua, opcua
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-400, CWE-770
Reviewed
2022-08-30

Affected packages

• PyPI asyncua: < 0.9.96 → fixed in 0.9.96 • PyPI opcua: <= 0.98.13 (no fix yet)

Description

All versions of package opcua; all versions of package asyncua are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

Related

Alias · CVE (1)

  • CVE-2022-25304 All versions of package opcua; all versions of package asyncua are vulnerable to Denial of Service (DoS) due to a missing limitation on the… vulnerability

Weakness · CWE (2)

  • CWE-400 Uncontrolled Resource Consumption weakness
  • CWE-770 Allocation of Resources Without Limits or Throttling weakness

References