GitHub Advisoryadvisory · PyPI
GHSA-mg66-qvc5-rm93 Missing validation causes denial of service via `SparseTensorToCSRSparseMatrix`
MEDIUM
Official page ↗
- Aliases
- CVE-2022-29198
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-05-24
Affected packages
• PyPI tensorflow: < 2.6.4 → fixed in 2.6.4
• PyPI tensorflow: >= 2.7.0, < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-cpu: < 2.6.4 → fixed in 2.6.4
• PyPI tensorflow-cpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-gpu: < 2.6.4 → fixed in 2.6.4
• PyPI tensorflow-gpu: >= 2.7.0, < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
Description
Impact
The implementation of `tf.raw_ops.SparseTensorToCSRSparseMatrix` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack:
```python
import tensorflow as tf
indices = tf.constant(53, shape=[3], dtype=tf.int64)
values = tf.constant(0.554979503, shape=[218650], dtype=tf.float32)
dense_shape = tf.constant(53, shape=[3], dtype=tf.int64)
tf.raw_ops.SparseTensorToCSRSparseMatrix(
indices=indices,
values=values,
dense_shape=dense_shape)
```
The code assumes `dense_shape` is a vector and `indices` is a matrix (as part of requirements for sparse tensors) but there is no validation for this:
```cc
const Tensor& indices = ctx->input(0);
const Tensor& values = ctx->input(1);
const Tensor& dense_shape = ctx->input(2);
const int rank = dense_shape.NumElements();
OP_REQUIRES(ctx, rank == 2 || rank == 3,
errors::InvalidArgument("SparseTensor must have rank 2 or 3; ",
"but indices has rank: ", rank));
auto dense_shape_vec = dense_shape.vec();
// ...
OP_REQUIRES_OK(
ctx,
coo_to_csr(batch_size, num_rows, indices.template matrix(),
batch_ptr.vec(), csr_row_ptr.vec(),
csr_col_ind.vec()));
```
Patches
We have patched the issue in GitHub commit ea50a40e84f6bff15a0912728e35b657548cef11.
The fix will be included in TensorFlow 2.9.0. We will also cherrypick this commit on TensorFlow 2.8.1, TensorFlow 2.7.2, and TensorFlow 2.6.4, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou from Secure Systems Lab at Brown University.
Related
Alias · CVE (1)
- CVE-2022-29198 TensorFlow is an open source platform for machine learning. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mg66-qvc5-rm93 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-29198 advisory
- https://github.com/tensorflow/tensorflow/commit/ea50a40e84f6bff15a0912728e35b657548cef11 web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/kernels/sparse/sparse_tensor_to_csr_sparse_matrix_op.cc#L65-L119 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1 web
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0 web