GitHub Advisoryadvisory · Packagist

GHSA-mg69-5q59-8jcg Moodle does not enforce the moodle/site:accessallgroups capability requirement

MEDIUM Published 2022-05-13 Modified 2024-01-24 Official page ↗
Aliases
CVE-2014-3553
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
Reviewed
2024-01-24

Affected packages

• Packagist moodle/moodle: < 2.5.7 → fixed in 2.5.7 • Packagist moodle/moodle: >= 2.6.0, < 2.6.4 → fixed in 2.6.4 • Packagist moodle/moodle: >= 2.7.0, < 2.7.1 → fixed in 2.7.1

Description

mod/forum/classes/post_form.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before 2.7.1 does not enforce the moodle/site:accessallgroups capability requirement before proceeding with a post to all groups, which allows remote authenticated users to bypass intended access restrictions by leveraging two or more group memberships.

Related

Alias · CVE (1)

  • CVE-2014-3553 mod/forum/classes/post_form.php in Moodle through 2.3.11, 2.4.x before 2.4.11, 2.5.x before 2.5.7, 2.6.x before 2.6.4, and 2.7.x before… vulnerability

References