GitHub Advisoryadvisory · Go
GHSA-mgh9-4mwp-fg55 OpenFGA Authorization Bypass
MEDIUM
Official page ↗
- Aliases
- CVE-2025-55213
- Ecosystem
- Go
- Packages
- github.com/openfga/openfga
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- Weaknesses
- CWE-863
- Reviewed
- 2025-08-18
Affected packages
• Go github.com/openfga/openfga: >= 1.9.3, < 1.9.5 → fixed in 1.9.5
Description
Overview
OpenFGA v1.9.3 to v1.9.4 ( openfga-0.2.40 <= Helm chart <= openfga-0.2.41, v1.9.3 <= docker <= v.1.9.4) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed.
Am I Affected?
You are affected by this vulnerability if you are using OpenFGA v1.9.3 to v1.9.4, specifically under the following preconditions:
• Calling Check API or ListObjects with an authorization model that has a relationship directly assignable by more than 1 userset with same type, and
• There are check or list object queries that rely on the above relationship, and
• You have userset tuples that are assigned to the above relationship
Fix
Upgrade to v1.9.5. This upgrade is backwards compatible.
Workaround
Downgrade to v1.9.2 with enable-check-optimizations removed from OPENFGA_EXPERIMENTALS
Acknowledgments
OpenFGA would like Dominic Harries and rrozza-apolitical to thank for discovering this vulnerability.
Related
Alias · CVE (1)
- CVE-2025-55213 OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/openfga/openfga/security/advisories/GHSA-mgh9-4mwp-fg55 web
- https://nvd.nist.gov/vuln/detail/CVE-2025-55213 advisory
- https://github.com/openfga/openfga/commit/1a7e0e37fc4777c824b2386cac4867a66f3480b0 web
- https://github.com/openfga/openfga package
- https://pkg.go.dev/vuln/GO-2025-3894 web