GitHub Advisoryadvisory · Packagist

GHSA-mhfv-9h99-jwg7 Mediawiki Improper Privilege Management

MEDIUM Published 2022-05-13 Modified 2024-05-15 Official page ↗
Aliases
CVE-2018-0503
Ecosystem
Packagist
Packages
mediawiki/core
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Weaknesses
CWE-269
Reviewed
2024-05-15

Affected packages

• Packagist mediawiki/core: >= 1.27.0, < 1.27.5 → fixed in 1.27.5 • Packagist mediawiki/core: >= 1.29.0, < 1.29.3 → fixed in 1.29.3 • Packagist mediawiki/core: >= 1.30.0, < 1.30.1 → fixed in 1.30.1 • Packagist mediawiki/core: >= 1.31.0, < 1.31.1 → fixed in 1.31.1

Description

Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where contrary to the documentation, $wgRateLimits entry for 'user' overrides that for 'newbie'.

Related

Alias · CVE (1)

  • CVE-2018-0503 Mediawiki 1.31 before 1.31.1, 1.30.1, 1.29.3 and 1.27.5 contains a flaw where contrary to the documentation, $wgRateLimits entry for 'user'… vulnerability

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References