GitHub Advisoryadvisory · Maven
GHSA-mhp7-3393-pfqr Cross-site Scripting vulnerability in Jenkins
HIGH
Official page ↗
- Aliases
- CVE-2022-34172
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-22, CWE-79
- Reviewed
- 2022-12-06
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: >= 2.340, < 2.356 → fixed in 2.356
• Maven org.jenkins-ci.main:jenkins-core: >= 2.332, < 2.332.4 → fixed in 2.332.4
Description
Since Jenkins 2.340, symbol-based icons unescape previously escaped values of `tooltip` parameters.
This vulnerability is known to be exploitable by attackers with Job/Configure permission.
Jenkins 2.356, LTS 2.332.4 and LTS 2.346.1 addresses this vulnerability. Symbol-based icons no longer unescape values of `tooltip` parameters.
Related
Alias · CVE (1)
- CVE-2022-34172 In Jenkins 2.340 through 2.355 (both inclusive) symbol-based icons unescape previously escaped values of 'tooltip' parameters, resulting in… vulnerability