GitHub Advisoryadvisory · Maven

GHSA-mhww-p97m-3368 AWS-JDBC Wrapper: Privilege Escalation in Aurora PostgreSQL instance

HIGH Published 2026-07-17 Modified 2026-07-17 Official page ↗
Aliases
CVE-2026-11400
Ecosystem
Maven
Packages
software.amazon.jdbc:aws-advanced-jdbc-wrapper
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-426
Reviewed
2026-07-17

Affected packages

• Maven software.amazon.jdbc:aws-advanced-jdbc-wrapper: >= 3.0.0, < 4.0.1 → fixed in 4.0.1

Description

Aurora PostgreSQL is a fully managed relational database engine that's compatible with PostgreSQL. The team has identified CVE-2026-11400, an issue in Aurora PostgreSQL using the AWS Advanced JDBC Wrapper Impact An issue in AWS Wrappers for Amazon Aurora PostgreSQL will allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. Impacted versions: AWS Advanced JDBC Wrapper >= 3.0.0 and < 4.0.1 Patches This issue has been addressed in AWS JDBC Wrapper v4.0.1. It is recommended to upgrade to the latest version and ensuring any forked or derivative code is patched to incorporate the new fixes. Workarounds Remove the public schema from the search path. Resources If there are any questions or comments about this advisory, contact [AWS/Amazon] Security via vulnerability reporting page or directly via email to [email protected]. Please do not create a public GitHub issue. Acknowledgement AWS-JDBC Wrapper would like to thank x.com/ph0smet for collaborating on this issue through the coordinated vulnerability disclosure process.

Related

Alias · CVE (1)

  • CVE-2026-11400 An untrusted search path issue in the GlobalDatabasePlugin in the AWS Advanced JDBC Wrapper for Amazon Aurora PostgreSQL will allow a… vulnerability

Weakness · CWE (1)

  • CWE-426 Untrusted Search Path weakness

References