GitHub Advisoryadvisory · npm

GHSA-mj46-r4gr-5x83 Unsanitized JavaScript code injection possible in gatsby-plugin-mdx

HIGH Published 2022-06-03 Modified 2022-06-06 Official page ↗
Aliases
CVE-2022-25863
Ecosystem
npm
Packages
gatsby-plugin-mdx
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-502
Reviewed
2022-06-03

Affected packages

• npm gatsby-plugin-mdx: < 2.14.1 → fixed in 2.14.1 • npm gatsby-plugin-mdx: >= 3.0.0, < 3.15.2 → fixed in 3.15.2

Description

Impact The gatsby-plugin-mdx plugin prior to versions 3.15.2 and 2.14.1 passes input through to the `gray-matter` npm package, which is vulnerable to JavaScript injection in its default configuration, unless input is sanitized. The vulnerability is present when passing input in both webpack (MDX files in `src/pages` or MDX file imported as component in frontend / React code) and data mode (querying MDX nodes via GraphQL). Injected JavaScript executes in the context of the build server. To exploit this vulnerability untrusted/unsanitized input would need to be sourced or added into an MDX file. The following MDX payload demonstrates a vulnerable configuration: ``` ---js ((require("child_process")).execSync("id >> /tmp/rce")) --- ``` Patches A patch has been introduced in `[email protected]` and `[email protected]` which mitigates the issue by disabling the `gray-matter` JavaScript Frontmatter engine. The patch introduces a new option, `JSFrontmatterEngine` which is set to `false` by default. When setting `JSFrontmatterEngine` to `true`, input passed to `gatsby-plugin-mdx` must be sanitized before processing to avoid a security risk. Warnings are displayed when enabling `JSFrontmatterEngine` to `true` or if it appears that the MDX input is attempting to use the Frontmatter engine. Workarounds If an older version of `gatsby-plugin-mdx` must be used, input passed into the plugin should be sanitized ahead of processing. We encourage projects to upgrade to the latest major release branch for all Gatsby plugins to ensure the latest security updates and bug fixes are received in a timely manner. Credits We would like to thank Snyk [snyk.io] for initially bringing the issue to our attention, as well as Feng Xiao and Zhongfu Su, who reported the issue to Snyk. For more information Email us at [email protected].

Related

Alias · CVE (1)

  • CVE-2022-25863 The package gatsby-plugin-mdx before 2.14.1, from 3.0.0 and before 3.15.2 are vulnerable to Deserialization of Untrusted Data when passing… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References