GitHub Advisoryadvisory · Maven

GHSA-mj5v-ggjc-48p5 XXE vulnerability in Jenkins OWASP Dependency-Check Plugin

HIGH Published 2022-05-24 Modified 2023-10-27 Official page ↗
Aliases
CVE-2021-43577
Ecosystem
Maven
Packages
org.jenkins-ci.plugins:dependency-check-jenkins-plugin
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Weaknesses
CWE-611
Reviewed
2022-12-15

Affected packages

• Maven org.jenkins-ci.plugins:dependency-check-jenkins-plugin: < 5.1.2 → fixed in 5.1.2

Description

Jenkins OWASP Dependency-Check Plugin 5.1.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. This allows attackers able to control workspace contents to have Jenkins parse a crafted XML file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.

Related

Alias · CVE (1)

  • CVE-2021-43577 Jenkins OWASP Dependency-Check Plugin 5.1.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. vulnerability

Weakness · CWE (1)

  • CWE-611 Improper Restriction of XML External Entity Reference weakness

References