GitHub Advisoryadvisory · npm
GHSA-mj6p-3pc9-wf5m proxy denial of service vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2023-2968
- Ecosystem
- npm
- Packages
- proxy
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-232
- Reviewed
- 2023-06-06
Affected packages
• npm proxy: >= 2.0.0, < 2.1.1 → fixed in 2.1.1
Description
A remote attacker can trigger a denial of service in the `socket.remoteAddress` variable, by sending a crafted HTTP request. Usage of the undefined variable raises a TypeError exception.
Related
Alias · CVE (1)
- CVE-2023-2968 A remote attacker can trigger a denial of service in the socket.remoteAddress variable, by sending a crafted HTTP request. vulnerability
Weakness · CWE (1)
- CWE-232 Improper Handling of Undefined Values weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-2968 advisory
- https://github.com/TooTallNate/proxy-agents/pull/178 web
- https://github.com/TooTallNate/proxy-agents/commit/25e0c931390eb8f41c5ceaca72820de9198ece39 web
- https://github.com/TooTallNate/proxy-agents package
- https://research.jfrog.com/vulnerabilities/undefined-variable-usage-in-proxy-leads-to-remote-denial-of-service-xray-520917 web